API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CrossSectionSelect Method (Double, Double)

Selects the cross section from the profile definition.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.1
Syntax
public bool Select(
	double Location = 0,
	double Length = 1000
)

Parameters

Location (Optional)
Type: SystemDouble
The location from where cross section is fetched.
Length (Optional)
Type: SystemDouble
The total length of the profile.

Return Value

Type: Boolean
True in success.
See Also