![]() | ConicalSurfaceNode Class |
The ConicalSurfaceNode class represents conical surface geometry tree node.

Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The ConicalSurfaceNode type exposes the following members.

Name | Description | |
---|---|---|
![]() | ConicalSurfaceNode |
Initializes a new instance of the ConicalSurfaceNode class.
|

Name | Description | |
---|---|---|
![]() | IsAutomatic |
Gets a value indicating whether this geometry node was automatically generated (returns false if it was originally a user-defined part)
(Inherited from BendSurfaceNode.) |
![]() | Surface |
Gets the conical surface geometry.
|

Name | Description | |
---|---|---|
![]() | AcceptVisitor |
Entry method for the visitor pattern.
(Overrides BendSurfaceNodeAcceptVisitor(IGeometryNodeVisitor).) |
![]() | Clone |
Creates a new object that is a copy of the current instance.
(Overrides BendSurfaceNodeClone.) |