![]() | ConicalSurface Constructor (Vector, Vector, LineSegment, LineSegment) |
Initializes a new instance of the ConicalSurface class with given parameters.
The boundaries are defined by the side boundaries (i.e. generator lines of the cone).
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

public ConicalSurface( Vector endFaceNormal1, Vector endFaceNormal2, LineSegment sideBoundary1, LineSegment sideBoundary2 )
Parameters
- endFaceNormal1
- Type: Tekla.Structures.Geometry3dVector
The first end face normal. - endFaceNormal2
- Type: Tekla.Structures.Geometry3dVector
The second end face normal. - sideBoundary1
- Type: Tekla.Structures.Geometry3dLineSegment
The first side boundary. - sideBoundary2
- Type: Tekla.Structures.Geometry3dLineSegment
The second side boundary.

Exception | Condition |
---|---|
ArgumentNullException | Throws exception if one of the arguments has null value. |

This constructor may be numerically instable if the end faces are very close