API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingGetPlotFileName Method

Get plot file name.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public string GetPlotFileName(
	bool includeRevisionInfo
)

Parameters

includeRevisionInfo
Type: SystemBoolean
Whether to include revision info.

Return Value

Type: String
The plot file name or an empty string if an error occured.
Remarks
Note: The returned plot file name can contain invalid file name characters.
See Also