API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

TeklaStructuresSettingsIsToolOptionOn Method

Determines whether select switch is on.

Namespace:  Tekla.Structures
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public static bool IsToolOptionOn(
	string toolOptionName
)

Parameters

toolOptionName
Type: SystemString
Name of the switch.

Return Value

Type: Boolean
true if select switch is on; otherwise, false.
See Also