API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PointCloudSetVisibility Method

Set point cloud visibility in given views.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool SetVisibility(
	List<View> views,
	bool visible
)

Parameters

views
Type: System.Collections.GenericListView
The views, in which the point clouds visibility is changed.
visible
Type: SystemBoolean
Visibility value: True for visible, false for hidden.

Return Value

Type: Boolean
True if successful to all given views, otherwise false.
See Also