API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

FacetedBrepWithNormals Constructor

Initializes a new instance of the FacetedBrepWithNormals class.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public FacetedBrepWithNormals(
	Vector[] vertices,
	int[][] outerWires,
	IDictionary<int, int[][]> innerWires,
	Vector[] normals
)

Parameters

vertices
Type: Tekla.Structures.Geometry3dVector
The vertex geometries.
outerWires
Type: SystemInt32
The outer wires as a two dimensional array. Integer indexes are used for identifying the corresponding vertex for the node in the wire from the array provided by parameter vertices.
innerWires
Type: System.Collections.GenericIDictionaryInt32, Int32
The inner wires also known as inner loops or holes.
normals
Type: Tekla.Structures.Geometry3dVector
Normal unit vectors for each vertex in vertices.
See Also