API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

FacetedBrepWithNormals Class

The FacetedBRepWithNormals class defines a faceted BREP that has also vertex normal vectors.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Geometry3dFacetedBrep
    Tekla.Structures.Geometry3dFacetedBrepWithNormals

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class FacetedBrepWithNormals : FacetedBrep

The FacetedBrepWithNormals type exposes the following members.

Constructors
  NameDescription
Public methodFacetedBrepWithNormals
Initializes a new instance of the FacetedBrepWithNormals class.
Top
Properties
  NameDescription
Public propertyFaces
Gets the faces.
(Inherited from FacetedBrep.)
Public propertyGetEdges
Gets the edges.
(Inherited from FacetedBrep.)
Public propertyInnerWires
Gets the inner wires.
(Inherited from FacetedBrep.)
Public propertyNormals
Gets or sets the vertex normal unit vectors
Public propertyOuterWires
Gets the outer wires.
(Inherited from FacetedBrep.)
Public propertyVertices
Gets the vertices.
(Inherited from FacetedBrep.)
Top
Methods
  NameDescription
Public methodCheckForTwoManifold
Gets a value indicating whether this instance is 2-manifold.
(Inherited from FacetedBrep.)
Public methodGetInnerFace
Gets the inner face at the specified index.
(Inherited from FacetedBrep.)
Public methodGetInnerFaceCount
Gets the inner face count of the outer face at the specified index.
(Inherited from FacetedBrep.)
Public methodGetOuterFace
Gets the outer face at the specified index.
(Inherited from FacetedBrep.)
Top
Examples
public void Example()
{
    /* See the method <b>InsertUsingNormals</b> in the <b>ShapeItem</b> class for a code example*/
}
See Also