API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

FacetedBrepWithNormals Class

The FacetedBRepWithNormals class defines a faceted BREP that has also vertex normal vectors.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Geometry3dFacetedBrep
    Tekla.Structures.Geometry3dFacetedBrepWithNormals

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class FacetedBrepWithNormals : FacetedBrep

The FacetedBrepWithNormals type exposes the following members.

Constructors
  NameDescription
Public methodFacetedBrepWithNormals
Initializes a new instance of the FacetedBrepWithNormals class.
Top
Properties
  NameDescription
Public propertyNormals
Gets or sets the vertex normal unit vectors
Top
Methods
  NameDescription
Top
Examples
public void Example()
{
    /* See the method <b>InsertUsingNormals</b> in the <b>ShapeItem</b> class for a code example*/
}
See Also