API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ViewBaseGetModelObjects Method

Gets the drawing model objects based on given model object identifier. If used from sheet model objects from all views are returned.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public DrawingObjectEnumerator GetModelObjects(
	Identifier ModelIdentifier
)

Parameters

ModelIdentifier
Type: Tekla.StructuresIdentifier
The identifier of the object in the model.

Return Value

Type: DrawingObjectEnumerator
The model objects.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.