![]() | WeldMarkWeldMarkAttributes Class |
The WeldMarkAttributes class is the attributes class for the weld mark attributes.

SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingWeldMarkWeldMarkAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingWeldMarkWeldMarkAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The WeldMarkWeldMarkAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | WeldMarkWeldMarkAttributes |
Creates a new default weld mark attributes instance that loads standard attributes.
|
![]() | WeldMarkWeldMarkAttributes(String) |
Creates a new weld mark attributes instance that loads the specified attributes.
|

Name | Description | |
---|---|---|
![]() | CustomPresentation |
Custom presentation GUID to be applied to the object type
|
![]() | Font |
The weld mark font settings.
|
![]() | SeamAbove |
The visibility of the seam above parameters.
|
![]() | SeamBelow |
The visibility of the seam below parameters.
|
![]() | ShowEdgeAround |
Gets or sets visibility of the weld mark edge/around property.
|
![]() | ShowReferenceText |
Gets or sets visibility of the weld mark reference text.
|
![]() | ShowWeldNumber |
The visibility of the weld number.
|
![]() | ShowWorkshopSite |
Gets or sets visibility of the weld mark workshop/site property.
|
![]() | TransparentBackground |
Controls the text background transparency (transparent/opaque).
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |