API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

WeldMarkSeamVisibilityAttributes Constructor (Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

Creates a new weld seam visibility attributes instance with the given attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1
Syntax
public SeamVisibilityAttributes(
	bool showPrefix,
	bool showSize,
	bool showType,
	bool showAngle,
	bool showContour,
	bool showFinish,
	bool showLength,
	bool showPitch,
	bool showEffectiveThroat,
	bool showRootOpening
)

Parameters

showPrefix
Type: SystemBoolean
The seam prefix visibility to be used.
showSize
Type: SystemBoolean
The seam size visibility to be used.
showType
Type: SystemBoolean
The seam type visibility to be used.
showAngle
Type: SystemBoolean
The seam angle visibility to be used.
showContour
Type: SystemBoolean
The seam contour visibility to be used.
showFinish
Type: SystemBoolean
The seam finish visibility to be used.
showLength
Type: SystemBoolean
The seam length visibility to be used.
showPitch
Type: SystemBoolean
The seam pitch visibility to be used.
showEffectiveThroat
Type: SystemBoolean
The seam effective throat visibility to be used.
showRootOpening
Type: SystemBoolean
The seam root opening visibility to be used.
See Also