![]() | WeldMarkSeamVisibilityAttributes Class |
The SeamVisibilityAttributes class is the attributes class for the weld seam visibility.

SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingWeldMarkSeamVisibilityAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingWeldMarkSeamVisibilityAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.1

The WeldMarkSeamVisibilityAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | WeldMarkSeamVisibilityAttributes |
Creates a new weld seam visibility attributes instance.
|
![]() | WeldMarkSeamVisibilityAttributes(Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) |
Creates a new weld seam visibility attributes instance with the given attributes.
|

Name | Description | |
---|---|---|
![]() | ShowAngle |
Gets or sets a value indicating whether the seam angle is visible.
|
![]() | ShowContour |
Gets or sets a value indicating whether the seam contour is visible.
|
![]() | ShowEffectiveThroat |
Gets or sets a value indicating whether the seam effective throat is visible.
|
![]() | ShowFinish |
Gets or sets a value indicating whether the seam finish is visible.
|
![]() | ShowLength |
Gets or sets a value indicating whether the seam length is visible.
|
![]() | ShowPitch |
Gets or sets a value indicating whether the seam pitch is visible.
|
![]() | ShowPrefix |
Gets or sets a value indicating whether the seam prefix is visible.
|
![]() | ShowRootOpening |
Gets or sets a value indicating whether the seam root opening is visible.
|
![]() | ShowSize |
Gets or sets a value indicating whether the seam size is visible.
|
![]() | ShowType |
Gets or sets a value indicating whether the seam type is visible.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |