![]() | WpfShapeCatalog Class |
The WpfShapeCatalog class represents a group of controls to select shapes
using the shape catalog.
WpfShapeCatalog

SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfShapeCatalog
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfShapeCatalog
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1

The WpfShapeCatalog type exposes the following members.

Name | Description | |
---|---|---|
![]() | WpfShapeCatalog |
Initializes a new instance of the ShapeCatalog class.
|
![]() | WpfShapeCatalog(String) |
Initializes a new instance of the ShapeCatalog class and will select
the Shape (if available) in the tree.
|

Name | Description | |
---|---|---|
![]() | ButtonHeight |
Gets and sets the height of the button control.
|
![]() | ButtonText |
Gets and sets the text of the button control.
|
![]() | ButtonWidth |
Gets and sets the width of the button control.
|
![]() | SelectedShape |
Gets or sets the selected Shape in the control.
|

Name | Description | |
---|---|---|
![]() | InitializeComponent |
InitializeComponent
|
![]() | OnValueChanged |
Event handler for passing generic catalog data back to dialog
|

Name | Description | |
---|---|---|
![]() | SelectClicked |
The SelectClicked event is raised when the Select button is clicked.
|
![]() | SelectionDone |
The SelectionDone event is raised when the selection has been done.
|