![]() | WpfReinforcementCatalog Class |
The WpfReinforcementCatalog class represents a group of controls to select rebars
using the reinforcement catalog.
WpfReinforcementCatalog

SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfReinforcementCatalog
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfReinforcementCatalog
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1

The WpfReinforcementCatalog type exposes the following members.

Name | Description | |
---|---|---|
![]() | WpfReinforcementCatalog |
Initiates a new instance of the control.
|
![]() | WpfReinforcementCatalog(String, String, Double) |
Creates a new instance of the ReinforcementCatalog and will select in the tree
the rebar that contains the given parameters (if possible).
|

Name | Description | |
---|---|---|
![]() | ButtonHeight |
Gets and sets the height of the button control.
|
![]() | ButtonText |
Gets and sets the text of the button control.
|
![]() | ButtonWidth |
Gets and sets the width of the button control.
|
![]() | SelectedRebarBendingRadius |
Gets the selected rebar bending radius in the control.
|
![]() | SelectedRebarGrade |
Gets the selected rebar grade in the control.
|
![]() | SelectedRebarSize |
Gets the selected rebar size in the control.
|
![]() | SelectedUsage |
Gets the selected rebar usage in the control.
|

Name | Description | |
---|---|---|
![]() | InitializeComponent |
InitializeComponent
|
![]() | OnValueChanged |
Event handler for passing generic catalog data back to dialog
|

Name | Description | |
---|---|---|
![]() | SelectClicked |
The SelectClicked event is raised when the Select button is clicked.
|
![]() | SelectionDone |
The SelectionDone event is raised when the selection has been done.
|