![]() | WpfProfileCatalog Class |
The WpfProfileCatalog class represents a group of controls to select profiles
using the profile catalog.
WpfProfileCatalog

SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfProfileCatalog
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfProfileCatalog
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1

The WpfProfileCatalog type exposes the following members.

Name | Description | |
---|---|---|
![]() | WpfProfileCatalog |
Initiates a new instance of the control.
|
![]() | WpfProfileCatalog(String) |
Initiates a new instance of the control selecting the given profile.
|

Name | Description | |
---|---|---|
![]() | ButtonHeight |
Gets and sets the height of the button control.
|
![]() | ButtonText |
Gets and sets the text of the button control.
|
![]() | ButtonWidth |
Gets and sets the width of the button control.
|
![]() | SelectedProfile |
The selected profile in the control.
|

Name | Description | |
---|---|---|
![]() | InitializeComponent |
InitializeComponent
|

Name | Description | |
---|---|---|
![]() | SelectClicked |
The SelectClicked event is raised when the Select button is clicked.
|
![]() | SelectionDone |
The SelectionDone event is raised when the selection has been done.
|