![]() | WpfMaterialCatalog Class |
The WpfMaterialCatalog class represents a group of controls to select materials
using the material catalog.
WpfMaterialCatalog

SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfMaterialCatalog
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfMaterialCatalog
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1

The WpfMaterialCatalog type exposes the following members.

Name | Description | |
---|---|---|
![]() | WpfMaterialCatalog |
Initiates a new instance of the control.
|
![]() | WpfMaterialCatalog(String) |
Creates a new instance of the MaterialCatalog and will select
the material (if available) in the tree.
|

Name | Description | |
---|---|---|
![]() | ButtonHeight |
Gets and sets the height of the button control.
|
![]() | ButtonText |
Gets and sets the text of the button control.
|
![]() | ButtonWidth |
Gets and sets the width of the button control.
|
![]() | SelectedMaterial |
Gets the selected material in the control.
|

Name | Description | |
---|---|---|
![]() | InitializeComponent |
InitializeComponent
|

Name | Description | |
---|---|---|
![]() | SelectClicked |
The SelectClicked event is raised when the Select button is clicked.
|
![]() | SelectionDone |
The SelectionDone event is raised when the selection has been done.
|