![]() | WpfCreateApplyCancel Class |
Interaction logic for WPFCreateAppyCancel.xaml.
Control is meant to be used with non-dependent plug-ins
WpfCreateApplyCancel

SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfCreateApplyCancel
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.Windows.ControlsUserControl
Tekla.Structures.Dialog.UIControlsWpfCreateApplyCancel
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1

The WpfCreateApplyCancel type exposes the following members.

Name | Description | |
---|---|---|
![]() | WpfCreateApplyCancel |
Constructor
|

Name | Description | |
---|---|---|
![]() | InitializeComponent |
InitializeComponent
|

Name | Description | |
---|---|---|
![]() | ApplyClicked |
The ApplyClicked event is raised when the Apply button is clicked.
|
![]() | CancelClicked |
The CancelClicked event is raised when the Cancel button is clicked.
|
![]() | CreateClicked |
The ApplyClicked event is raised when the Apply button is clicked.
|