WpfComponentCatalog Class

The WpfComponentCatalog class represents a group of controls to select components using the component catalog.
WpfComponentCatalog
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
public class WpfComponentCatalog : UserControl, 
	IComponentConnector

The WpfComponentCatalog type exposes the following members.

Constructors
  NameDescription
Public methodWpfComponentCatalog
Initializes a new instance of the WpfComponentCatalog class.
Top
Properties
  NameDescription
Public propertyButtonHeight
Gets and sets the height of the button control.
Public propertyButtonText
Gets and sets the text of the button control.
Public propertyButtonWidth
Gets and sets the width of the button control.
Public propertySelectedName
Gets or sets the selected component name in the control.
Public propertySelectedNumber
Gets or sets the selected component number in the control.
Top
Methods
  NameDescription
Public methodInitializeComponent
InitializeComponent
Top
Events
  NameDescription
Public eventSelectClicked
The SelectClicked event is raised when the Select button is clicked.
Public eventSelectionDone
The SelectionDone event is raised when the selection has been done.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next