API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CustomObservableCollectionT Constructor (IEnumerableT)

CustomObservableCollection constructor.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public CustomObservableCollection(
	IEnumerable<T> collection
)

Parameters

collection
Type: System.Collections.GenericIEnumerableT
The collection used in creation.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.