API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

WindowBaseGetUnitDecimals Method

Gets the number of decimals Tekla Structures uses with the specified unit type.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public static int GetUnitDecimals(
	dotdiaUnitTypes_e unit
)

Parameters

unit
Type: Tekla.Structures.DialogdotdiaUnitTypes_e
The specified unit type.

Return Value

Type: Int32
The number of decimals used, 0 (no decimals or invalid unit type) or -1 (failed).
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.