API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StructuresDialogAttribute Constructor (String, Type)

Initializes a new StructuresDialogAttribute instance.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public StructuresDialogAttribute(
	string attributeName,
	Type attributeType
)

Parameters

attributeName
Type: SystemString
The attribute name of the property.
attributeType
Type: SystemType
The attribute type of the property.
See Also