API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

VertexEnumerator Class

The VertexEnumerator class is used to enumerate the vertexes of a loop instance.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.SolidVertexEnumerator

Namespace:  Tekla.Structures.Solid
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public sealed class VertexEnumerator : IEnumerator

The VertexEnumerator type exposes the following members.

Properties
  NameDescription
Public propertyCurrent
Returns the current vertex.
Top
Methods
  NameDescription
Public methodMoveNext
Moves to the next item in the enumerator.
Public methodReset
Resets the enumerator to the beginning.
Top
See Also