API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ISolid Interface

The ISolid interface represents a physical object in the model or a drawing created by a part instance. The solid instance can be used to query the actual geometry of the part.

Namespace:  Tekla.Structures.Solid
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public interface ISolid

The ISolid type exposes the following members.

Properties
  NameDescription
Public propertyMaximumPoint
The maximum axis-aligned point of the solid in the current plane.
Public propertyMinimumPoint
The minimum axis-aligned point of the solid in the current plane.
Top
Methods
  NameDescription
Public methodGetEdgeEnumerator
Returns a new edge enumerator in the current plane.
Public methodGetFaceEnumerator
Returns a new face enumerator in the current plane.
Top
See Also