API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Edge Class

The Edge class represents a single global edge in a solid.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.SolidEdge

Namespace:  Tekla.Structures.Solid
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.1
Syntax
public sealed class Edge : ICloneable

The Edge type exposes the following members.

Properties
  NameDescription
Public propertyEndPoint
Gets the end point of the edge.
Public propertyStartPoint
Gets the start point of the edge.
Public propertyType
Gets the type of the edge.
Top
Methods
  NameDescription
Public methodClone
Method for cloning the current object.
Top
See Also