![]() | Tekla.Structures.Solid Namespace |
The Tekla.Structures.Solid namespace contains basic common solid related types that are shared between Tekla Structures Model and Drawing.

Class | Description | |
---|---|---|
![]() | Edge |
The Edge class represents a single global edge in a solid.
|
![]() ![]() | EdgeEnumerator |
The EdgeEnumerator class is used to enumerate the edges of a solid.
|
![]() | Face |
The Face class represents a single face in a solid.
|
![]() | FaceEnumerator |
The FaceEnumerator class is used to enumerate the faces of a solid.
|
![]() | Loop |
The Loop class represents a single loop in a face.
|
![]() | LoopEnumerator |
The LoopEnumerator class is used to enumerate the loops of a face instance.
|
![]() | Shell |
The Shell class represents a single shell in a solid.
|
![]() ![]() | ShellEnumerator |
The ShellEnumerator class is used to enumerate the shells of a solid.
|
![]() | VertexEnumerator |
The VertexEnumerator class is used to enumerate the vertexes of a loop instance.
|

Interface | Description | |
---|---|---|
![]() | ISolid |
The ISolid interface represents a physical object in the model or a drawing created by a part instance.
The solid instance can be used to query the actual geometry of the part.
|

Enumeration | Description | |
---|---|---|
![]() | EdgeEdgeTypeEnum |
The type of the edge.
|