API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StructuresFieldAttribute Class

The StructuresFieldAttribute class is used for mapping a database attribute to a data field that the plug-in uses in execution. The attribute is initialized from the custom attribute [StructuresField(attributeName)] in the plug-in source. In the plug-in the data field must be public and the type must be double, integer or string.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.PluginsStructuresFieldAttribute

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.1
Syntax
public sealed class StructuresFieldAttribute : Attribute

The StructuresFieldAttribute type exposes the following members.

Constructors
  NameDescription
Public methodStructuresFieldAttribute
The custom attribute [StructuresField(attributeName)] uses this to map a database attribute to a data field that the plug-in uses in execution. This is not to be used by itself.
Top
Properties
  NameDescription
Public propertyAttributeName
The name of the attribute.
Top
See Also