![]() | SecondaryTypeAttribute Class |
The SecondaryTypeAttribute class is used for storing the number of needed secondaries in the connection.
Based on the type the system can then correctly ask for user input in the creation.
The attribute is initialized from the custom attribute i.e.
[SecondaryType(ConnectionBase.SecondaryType.SECONDARYTYPE_ONE)]
in the connection source.

Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.1

The SecondaryTypeAttribute type exposes the following members.

Name | Description | |
---|---|---|
![]() | SecondaryTypeAttribute(Int32) |
The custom attribute [SecondaryType()] uses this to store the secondary type to the system.
This is not to be used by itself.
|
![]() | SecondaryTypeAttribute(ConnectionBaseSecondaryType) |
The custom attribute [SecondaryType()] uses this to store the secondary type to the system.
This is not to be used by itself.
|

Name | Description | |
---|---|---|
![]() | Type |
The custom attribute [SecondaryType()] uses this to store the secondary type to the system.
This is not to be used by itself.
|