API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SeamInputTypeAttribute Class

The SeamInputTypeAttribute class is used for identifying that the connection is a seam and defining the input type. Based on the type the system will then ask for the correct number of input points in the creation. The attribute is initialized from the custom attribute [SeamInputType(ConnectionBase.SeamInputType.INPUT_POLYGON)] in the connection source.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.PluginsSeamInputTypeAttribute

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.1
Syntax
public sealed class SeamInputTypeAttribute : Attribute

The SeamInputTypeAttribute type exposes the following members.

Constructors
  NameDescription
Public methodSeamInputTypeAttribute(Int32)
The custom attribute [SeamInputType()] uses this to store the input type to the system. This is not to be used by itself.
Public methodSeamInputTypeAttribute(ConnectionBaseSeamInputType)
The custom attribute [SeamInputType()] uses this to store the input type to the system. This is not to be used by itself.
Top
Properties
  NameDescription
Public propertyType
The custom attribute [SeamInputType()] uses this to store the input type to the system. This is not to be used by itself.
Top
See Also