API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PositionTypeAttribute Constructor (Int32)

The custom attribute [PositionType()] uses this to store the position type to the system. This is not to be used by itself.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.1
Syntax
public PositionTypeAttribute(
	int Type
)

Parameters

Type
Type: SystemInt32
The position type.
See Also