API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PluginBaseInputDefinitionInputTypeEnum Enumeration

The possible input types for a plug-in.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.1
Syntax
public enum InputTypeEnum
Members
  Member nameValueDescription
INPUT_ONE_POINT1 The input is one point (x,y,z).
INPUT_TWO_POINTS2 The input is two points.
INPUT_POLYGON3 The input is multiple points.
INPUT_ONE_OBJECT4 The input is one ID of any type.
INPUT_N_OBJECTS5 The input is N IDs of any type.
See Also