![]() | InputObjectTypeAttribute Class |
The InputObjectTypeAttribute class is used for storing the type of the input.
Based on the type the system can then correctly ask for user input in the creation.
The attribute is initialized from the custom attribute
[InputObjectType(ConnectionBase.InputObjectType.INPUTOBJECT_PART)]
in the connection source.

Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.1

The InputObjectTypeAttribute type exposes the following members.

Name | Description | |
---|---|---|
![]() | InputObjectTypeAttribute(Int32) |
The custom attribute [InputObjectType()] uses this to store the input object type to the system.
This is not to be used by itself.
|
![]() | InputObjectTypeAttribute(ConnectionBaseInputObjectType) |
The custom attribute [InputObjectType()] uses this to store the input object type to the system.
This is not to be used by itself.
|

Name | Description | |
---|---|---|
![]() | Type |
The custom attribute [InputObjectType()] uses this to store the input object type to the system.
This is not to be used by itself.
|