API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingPluginBaseInputDefinition Constructor (Identifier, Identifier)

Creates a new input definition instance with one identifier.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.1
Syntax
public InputDefinition(
	Identifier viewId,
	Identifier ObjectId
)

Parameters

viewId
Type: Tekla.StructuresIdentifier
The identifier for the view object.
ObjectId
Type: Tekla.StructuresIdentifier
The object identifier.
See Also