API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DrawingPluginBaseInputDefinition Constructor (Identifier, ListPoint)

Creates a new input definition with multiple points.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.1
Syntax
public InputDefinition(
	Identifier viewId,
	List<Point> points
)

Parameters

viewId
Type: Tekla.StructuresIdentifier
The view identifier.
points
Type: System.Collections.GenericListPoint
The points.
See Also