DrawingPluginBaseInputDefinition Class

The InputDefinition class is a class for defining the plug-in dependency over the input (points or identifiers). The user implemented method DefineInput() of the DrawingPluginBase interface should return an array list of input definition instances. This defines the points and identifiers the plug-in will receive as input when the Run() method is called.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Tekla.Structures.PluginsDrawingPluginBaseInputDefinition

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class InputDefinition : MarshalByRefObject

The DrawingPluginBaseInputDefinition type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyType
The type of the input the current instance contains.
Public propertyViewId
The view object's identifier.
Top
Methods
  NameDescription
Public methodGetInput
Returns the input Tekla Structures gave to the plug-in. The input is either a point instance, an identifier instance, an array list of points or an array list of identifiers. This is based on the input format returned from the DefineInput() method.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next