![]() | DrawingPluginBase Class |
The DrawingPluginBase class is an abstract base class for drawing plug-ins.

Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.1

The DrawingPluginBase type exposes the following members.

Name | Description | |
---|---|---|
![]() | DefineInput |
The method Tekla Structures calls for the plug-in to query the input.
The plug-in must then return an array list of input definition instances. The plug-in
will be dependent on the items it returns. Dependent means that if any of these
items change, for example the user moves the points, the plug-in will be re-run with new
input. DefineInput is not called during the re-run, and thus all the actual implementation
should be in the Run() method. The Run() method is always called in view coordinates.
|
![]() | InitializeLifetimeService |
Initializes the lifetime service.
(Overrides MarshalByRefObjectInitializeLifetimeService.) |
![]() | IsDefaultValue(Double) |
Returns true if the given value is set to the default value for this type.
|
![]() | IsDefaultValue(Int32) |
Returns true if the given value is set to the default value for this type.
|
![]() | IsDefaultValue(String) |
Returns true if the given value is set to the default value (empty string).
|
![]() | Run |
The main method of the plug-in. It is called after the input has been defined with
DefineInput(). This is the "main" method of the plug-in and should contain all the actual
implementation.
|