API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

DetailTypeAttribute Constructor (DetailTypeEnum)

The custom attribute [DetailType()] uses this to store the type of the detail to the system. This is not to be used by itself.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.1
Syntax
public DetailTypeAttribute(
	DetailTypeEnum Type
)

Parameters

Type
Type: Tekla.StructuresDetailTypeEnum
The detail type.
See Also