API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CustomPartPositioningTypeAttribute Class

The CustomPartInputTypeAttribute class is used for defining the input type. Based on the type the system will then position the custom part either based on calculated extrema center point or given input points. The attribute is initialized from the custom attribute i.e. [CustomPartPositioningType((CustomPartBase.CustomPartPositioningType.POSITIONING_BY_INPUTPOINTS)] in the custom part source code.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.PluginsCustomPartPositioningTypeAttribute

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.1
Syntax
public sealed class CustomPartPositioningTypeAttribute : Attribute

The CustomPartPositioningTypeAttribute type exposes the following members.

Constructors
  NameDescription
Public methodCustomPartPositioningTypeAttribute(Int32)
The custom attribute uses this to store the positioning type to the system. This is not to be used by itself.
Public methodCustomPartPositioningTypeAttribute(CustomPartBaseCustomPartPositioningType)
The custom attribute uses this to store the positioning type to the system. This is not to be used by itself.
Top
Properties
  NameDescription
Public propertyType
The custom attribute uses this to store the positioning type to the system. This is not to be used by itself.
Top
See Also