![]() | CustomPartInputTypeAttribute Class |
The CustomPartInputTypeAttribute class is used for defining the input type.
Based on the type the system will then ask for the correct number of input points in the creation.
The attribute is initialized from the custom attribute
[CustomPartInputType(CustomPartBase.CustomPartInputType.INPUT_1_POINT)]
in the custom part source code.

Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.1

The CustomPartInputTypeAttribute type exposes the following members.

Name | Description | |
---|---|---|
![]() | CustomPartInputTypeAttribute(Int32) |
The custom attribute uses this to store the input type to the system.
This is not to be used by itself.
|
![]() | CustomPartInputTypeAttribute(CustomPartBaseCustomPartInputType) |
The custom attribute uses this to store the input type to the system.
This is not to be used by itself.
|

Name | Description | |
---|---|---|
![]() | Type |
The custom attribute uses this to store the input type to the system.
This is not to be used by itself.
|