API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

AutoDirectionTypeAttribute Constructor (AutoDirectionTypeEnum)

The custom attribute [AutoDirectionType()] uses this to store the auto direction type to the system. This is not to be used by itself.

Namespace:  Tekla.Structures.Plugins
Assembly:  Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.1
Syntax
public AutoDirectionTypeAttribute(
	AutoDirectionTypeEnum Type
)

Parameters

Type
Type: Tekla.StructuresAutoDirectionTypeEnum
The auto direction type.
See Also