ViewHandler Class

The ViewHandler class contains methods for handling views.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.UIViewHandler

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ViewHandler

The ViewHandler type exposes the following members.

Constructors
  NameDescription
Public methodViewHandler
Initializes a new instance of the ViewHandler class
Top
Methods
  NameDescription
Public methodStatic memberGetAllViews
Fetches all the views from the model.
Public methodStatic memberGetPermanentViews
Returns the permanent views.
Public methodStatic memberGetSelectedViews
Returns the views the user has selected.
Public methodStatic memberGetTemporaryViews
Returns the temporary views.
Public methodStatic memberGetVisibleViews
Returns the visible views.
Public methodStatic memberHideView
Closes a model view.
Public methodStatic memberRedrawView
Redraws a model view.
Public methodStatic memberRedrawWorkplane
Sets the workplane to current transformation plane and redraws it.
Public methodStatic memberSetRepresentation
Sets the object representation.
Public methodStatic memberShowView
Opens a model view.
Public methodStatic memberCode exampleZoomToBoundingBox(AABB)
Zooms the current model view.
Public methodStatic memberZoomToBoundingBox(View, AABB)
Zooms a model view.
Top
Examples
using Tekla.Structures.Model.UI;

public class Example
{
       public void Example1()
       {
           ViewHandler.SetRepresentation("standard");
           ModelViewEnumerator ViewEnum = ViewHandler.GetAllViews();

           while (ViewEnum.MoveNext())
           {
               View ViewSel = ViewEnum.Current;
               ViewHandler.ShowView(ViewSel);
               ViewHandler.RedrawView(ViewSel);
               ViewHandler.HideView(ViewSel);
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next