API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerPickObjectsEnum Enumeration

The possible model object pick types for many objects.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public enum PickObjectsEnum
Members
  Member nameValueDescription
PICK_N_OBJECTS0 Pick multiple model objects of any type.
PICK_N_PARTS1 Pick multiple parts.
PICK_N_WELDS2 Pick multiple welds.
PICK_N_BOLTGROUPS3 Pick multiple bolt groups.
PICK_N_REINFORCEMENTS4 Pick multiple reinforcements.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.