API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerPickObjectEnum Enumeration

The possible model object pick types for a single object.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public enum PickObjectEnum
Members
  Member nameValueDescription
PICK_ONE_OBJECT0 Pick one model object of any type.
PICK_ONE_PART1 Pick one part.
PICK_ONE_WELD2 Pick one welding.
PICK_ONE_BOLTGROUP3 Pick one bolt group.
PICK_ONE_REINFORCEMENT4 Pick one reinforcement.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.