API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerPickPoints Method (PickerPickPointEnum)

Queries the user to pick points from the model.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ArrayList PickPoints(
	PickerPickPointEnum Enum
)

Parameters

Enum
Type: Tekla.Structures.Model.UIPickerPickPointEnum
Indicates how many points the user must pick.

Return Value

Type: ArrayList
A list of points the user picked.
See Also