API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerPickPoint Method (String)

Queries the user to pick a point from the model with the given prompt.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public Point PickPoint(
	string Prompt
)

Parameters

Prompt
Type: SystemString
The string to display as user guidance.

Return Value

Type: Point
The point the user picked.
See Also