API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PickerPickObject Method (PickerPickObjectEnum, String)

Queries the user to pick one model object from the model with the given prompt.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ModelObject PickObject(
	PickerPickObjectEnum Enum,
	string Prompt
)

Parameters

Enum
Type: Tekla.Structures.Model.UIPickerPickObjectEnum
Indicates the type of objects to pick.
Prompt
Type: SystemString
The string to display as user guidance.

Return Value

Type: ModelObject
One model object instance.
See Also