![]() | Picker Class |
The Picker class can be used to query the user to do manual picks of objects and points from the Tekla Structures model.
The methods throw an exception if the user interrupts (cancels) the pick command.

Namespace: Tekla.Structures.Model.UI
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The Picker type exposes the following members.


Name | Description | |
---|---|---|
![]() | PickFace |
Queries the user to pick a face from the model.
|
![]() | PickFace(String) |
Queries the user to pick a face from the model with the given prompt.
|
![]() | PickLine |
Queries the user to pick a line from the model.
|
![]() | PickLine(String) |
Queries the user to pick a line from the model with the given prompt.
|
![]() | PickObject(PickerPickObjectEnum) |
Queries the user to pick one model object from the model.
|
![]() | PickObject(PickerPickObjectEnum, String) |
Queries the user to pick one model object from the model with the given prompt.
|
![]() | PickObjects(PickerPickObjectsEnum) |
Queries the user to pick model objects from the model.
|
![]() | PickObjects(PickerPickObjectsEnum, String) |
Queries the user to pick model objects from the model with the given prompt.
|
![]() | PickPoint |
Queries the user to pick a point from the model.
|
![]() | PickPoint(String) |
Queries the user to pick a point from the model with the given prompt.
|
![]() | PickPoint(Point) |
Queries the user to pick a point from the model with reference to the given point.
|
![]() | PickPoint(String, Point) |
Queries the user to pick point with given prompt and reference to another point.
|
![]() | PickPoints(PickerPickPointEnum) |
Queries the user to pick points from the model.
|
![]() | PickPoints(PickerPickPointEnum, String) |
Queries the user to pick points from the model with the given prompt and reference to another point.
|

Prompts
Tekla Structures prefixes the given prompt with "prompt_" and looks for a translation in the prompts.ail file. If the translation (e.g. "prompt_Pick_first_position") is not found in the prompts.ail file, the prompt string is displayed as such. This feature can be used to give already translated strings to the picker.

using Tekla.Structures.Model.UI; using Tekla.Structures.Geometry3d; using System; using System.Windows.Forms; public class Example { public void Example1() { Picker Picker = new Picker(); Point p = null; try { p = Picker.PickPoint(); } catch (Exception e) { MessageBox.Show(e.ToString()); } } }