API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelViewEnumerator Class

The ModelViewEnumerator class is an enumerator class for model views. The enumerator enables model view items to be looped.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.UIModelViewEnumerator

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class ModelViewEnumerator : IEnumerator

The ModelViewEnumerator type exposes the following members.

Properties
  NameDescription
Public propertyCount
Returns the number of views in the enumerator.
Public propertyCurrent
Returns the current view.
Public propertyCurrentViewId
Gets the current view identifier.
Top
Methods
  NameDescription
Public methodMoveNext
Moves to the next view in the enumerator.
Public methodReset
Resets the enumerator.
Top
See Also