API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelObjectVisualizationSetTemporaryState Method (ListIdentifier, Color)

Sets visualization temporary state (red, blue, green and transparency) for given model object identifiers

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public static bool SetTemporaryState(
	List<Identifier> identifiers,
	Color color
)

Parameters

identifiers
Type: System.Collections.GenericListIdentifier

[Missing <param name="identifiers"/> documentation for "M:Tekla.Structures.Model.UI.ModelObjectVisualization.SetTemporaryState(System.Collections.Generic.List{Tekla.Structures.Identifier},Tekla.Structures.Model.UI.Color)"]

color
Type: Tekla.Structures.Model.UIColor

[Missing <param name="color"/> documentation for "M:Tekla.Structures.Model.UI.ModelObjectVisualization.SetTemporaryState(System.Collections.Generic.List{Tekla.Structures.Identifier},Tekla.Structures.Model.UI.Color)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Tekla.Structures.Model.UI.ModelObjectVisualization.SetTemporaryState(System.Collections.Generic.List{Tekla.Structures.Identifier},Tekla.Structures.Model.UI.Color)"]

See Also