API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

MeshAddTriangle Method

Adds a new triangle in the mesh.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public void AddTriangle(
	int Index1,
	int Index2,
	int Index3
)

Parameters

Index1
Type: SystemInt32
The index of the triangle's first point in the points array list.
Index2
Type: SystemInt32
The index of the triangle's second point in the points array list.
Index3
Type: SystemInt32
The index of the triangle's third point in the points array list.
See Also