API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Mesh Constructor (ArrayList, ArrayList, ArrayList)

Creates a new mesh instance with the given points, triangles and lines. Does not check the indices in the given triangles and lines array lists for correctness.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public Mesh(
	ArrayList Points,
	ArrayList Triangles,
	ArrayList Lines
)

Parameters

Points
Type: System.CollectionsArrayList
An array list of point objects representing the mesh points. Null represents no points.
Triangles
Type: System.CollectionsArrayList
An array list of indices (of type integer) pointing to the points array list. Three consecutive indices represent a single triangle. The first index is 0. If null, the mesh will not contain any triangles.
Lines
Type: System.CollectionsArrayList
An array list of indices (of type integer) pointing to the points array list. Two consecutive indices represent a single line. The first index is 0. If null, the mesh will not contain any lines.
See Also